Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 30, 2026 - 09:05 CDT
Scheduled
We are performing emergency maintenance on our Special Projects servers to apply critical security updates. During this time, UI elements such as Registration Pages, Management Dashboards, and certain Sync pages will be taken offline or experience degraded service. Thank you for your patience and understanding in this matter.
Posted Apr 30, 2026 - 09:00 CDT
This scheduled maintenance affected: SmarterU API.